POJ: Dining

dume0011
4 min readDec 3, 2021

--

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D
Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

Problem Analysis:

We can convert it to a max flow problem, then use ford-fulkerson algorithm to solve it.

We construct a graph. Construct a source vertex s and a target vertex t. Construct directed edges flow: s -> foods -> cows -> cows -> drink -> t.

Every edges’s capacity is 1, and reverse edge capacity is 0. Here cows -> cows make every cow has capacity 1. Then the max flow in t is the answer.

Solution

#include <cstdio>
#include <vector>
#include <queue>
using namespace std;#define MAX_N 100
#define MAX_F 100
#define MAX_D 100
#define MAX_V ((MAX_N) * 2 + (MAX_D) + (MAX_F) + 2)
#define INF 0x3f3f3f3f
struct SEdge {
int to;
int cap;
int rev;
SEdge(int t, int c, int r): to(t), cap(c), rev(r) {}
};
vector<SEdge> G[MAX_V];
int level[MAX_V];
int iter[MAX_V];
void add_edge(int from, int to, int cap) {
SEdge fromEdge(to, cap, (int)G[to].size());
G[from].push_back(fromEdge);
SEdge toEdge(from, 0, (int)G[from].size() - 1);
G[to].push_back(toEdge);
}
void bfs(int s) {
memset(level, -1, sizeof(level));
queue<int> q;
level[s] = 0;
q.push(s);
while (!q.empty()) {
int v = q.front();
q.pop();
for (int i = 0; i < G[v].size(); ++i) {
SEdge &e = G[v][i];
if (e.cap > 0 && level[e.to] < 0) {
level[e.to] = level[v] + 1;
q.push(e.to);
}
}
}
}
int dfs(int v, int t, int f) {
if (v == t) return f;
for (int &i = iter[v]; i < G[v].size(); ++i) {
SEdge &e = G[v][i];
if (e.cap > 0 && level[v] < level[e.to]) {
int d = dfs(e.to, t, min(f, e.cap));
if (d > 0) {
e.cap -= d;
G[e.to][e.rev].cap += d;
return d;
}
}
}
return 0;
}
int max_flow(int s, int t) {
int flow = 0;
while (true) {
bfs(s);
if (level[t] < 0) return flow;
memset(iter, 0, sizeof(iter));
int f;
while ((f = dfs(s, t, INF)) > 0) flow += f;
}
}
int main(int argc, char *argv[]) {
int N,F,D;
bool likeF[MAX_N][MAX_F];
bool likeD[MAX_N][MAX_D];
memset(likeF, '\0', sizeof(likeF));
memset(likeD, '\0', sizeof(likeD));
scanf("%d%d%d", &N, &F, &D); for (int i = 0; i < N; ++i) {
getchar();
int countF, countD;
scanf("%d%d", &countF, &countD);
for (int j = 0; j < countF; ++j) {
int k;
scanf("%d", &k);
likeF[i][k - 1] = true;
}
for (int j = 0; j < countD; ++j) {
int k;
scanf("%d", &k);
likeD[i][k - 1] = true;
}
}
// N~2N-1: cow in drink part
// 2N~2N+F-1: food
// 2N+F~2N+F+D-1: drink
int s = N * 2 + F + D;
int t = s + 1;
for (int i = 0; i < F; ++i)
add_edge(s, N * 2 + i, 1);
for (int i = 0; i < D; ++i)
add_edge(N * 2 + F + i, t, 1);

for (int i = 0; i < N; ++i) {
add_edge(i, N + i, 1);
for (int j = 0; j < F; ++j) {
if (likeF[i][j]) add_edge(N * 2 + j, i, 1);
}
for (int j = 0; j < D; ++j) {
if (likeD[i][j]) add_edge(N + i, N * 2 + F + j, 1);
}
}
printf("%d\n", max_flow(s, t));

return 0;
}

time complexity is ford-fulkerson algorithm O(EV²)

--

--